Rtlsdr

From Noisebridge
(Difference between revisions)
Jump to: navigation, search
(Created page with "sudo apt-get -y install libxi-dev mkdir src cd src git clone git://git.osmocom.org/rtl-sdr.git cd rtl-sdr/ mkdir build cd build sudo apt-get install cmake libusb-1.0-0-dev che...")
 
Line 1: Line 1:
 +
<pre>
 
sudo apt-get -y install libxi-dev
 
sudo apt-get -y install libxi-dev
 
mkdir src
 
mkdir src
Line 31: Line 32:
 
python-cheetah python-lxml doxygen qt4-dev-tools \
 
python-cheetah python-lxml doxygen qt4-dev-tools \
 
libqwt5-qt4-dev libqwtplot3d-qt4-dev pyqt4-dev-tools python-qwt5-qt4
 
libqwt5-qt4-dev libqwtplot3d-qt4-dev pyqt4-dev-tools python-qwt5-qt4
 +
</pre>

Revision as of 16:18, 2 March 2013

sudo apt-get -y install libxi-dev
mkdir src
cd src
git clone git://git.osmocom.org/rtl-sdr.git
cd rtl-sdr/
mkdir build
cd build
sudo apt-get install cmake libusb-1.0-0-dev checkinstall
cmake ../
make
sudo checkinstall
sudo ldconfig
sudo cp rtl-sdr.rules /etc/udev/rules.d/
sudo /etc/init.d/udev restart

rtl_test
                                                                                                                                                                                                                                                                              
and then to get gqrx, the graphical scanner, go to
http://sourceforge.net/projects/gqrx/files/latest/download

to install gnuradio, do the following commands:
sudo apt-get install libaudio-dev

sudo apt-get -y install libxi-dev

sudo apt-get -y install libfontconfig1-dev libxrender-dev libpulse-dev \
swig g++ automake autoconf libtool python-dev libfftw3-dev \
libcppunit-dev libboost-all-dev libusb-dev fort77 sdcc sdcc-libraries \
libsdl1.2-dev python-wxgtk2.8 git-core guile-1.8-dev \
libqt4-dev python-numpy ccache python-opengl libgsl0-dev \
python-cheetah python-lxml doxygen qt4-dev-tools \
libqwt5-qt4-dev libqwtplot3d-qt4-dev pyqt4-dev-tools python-qwt5-qt4
Personal tools