[Noisebridge-discuss] Bench Supply and Laser Cutter?

Zach R organicunity at hotmail.com
Thu Apr 30 14:29:48 UTC 2015


Hey all, 
  It was great to see some of the old faces at NB on Monday.  We had Michael L, Rubin, Jake, Miloh, Kevin and some other peeps of the OG variety holding it down !  Felt like old times :)

Me and Jake took a stab at the blown bench supply that everyone was using for years (the 15V x2 output adjustable one).  It's seen a lot of use, love, and abuse and it would be nice to have it going again.  It has been moved to the hackershelves now since it was taking a lot of time to repair and it got late.  Here is the diagnosis I made:

1) both outputs are good voltage-wise and adjust properly
2) Current control on both sides is shot, appears worse on the left as it actually displays a negative number (hah)
3) I believe the current is controlled by 2 logic chips using a sense resistor.  Those chips are CD1044 and CD4066 I believe.
4) I recommend replacing those chips and / or investigating the current control circuitry on the power converter board.
5) Note power converter boards have 2x pico fuses each that check out fine (they are yellow)


And I've been meaning to ask: what exactly is wrong with the laser cutter?  Does it need some expensive part?  I would LOVE to take a stab at repairing this since its one of the finest pieces of machinery we have at NB.

Best,
Zach


 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.noisebridge.net/pipermail/noisebridge-discuss/attachments/20150430/9a7e9818/attachment.html>


More information about the Noisebridge-discuss mailing list