[Noisebridge-discuss] Heat press fixed!

ng.kyle at gmail.com ng.kyle at gmail.com
Sun Mar 20 03:52:27 UTC 2016


Thank you so much Zack!! 
I could not find the correct fuse at NB but will pick one up.
I don't think there is a wiki page for the heat press though..

> On Mar 19, 2016, at 6:41 PM, Zach R <organicunity at hotmail.com> wrote:
> 
> Hey all,
> 
>    So I fixed the heatpress (again?) last night.  Kyle showed me the issue where it was blowing fuses and the fuse holder had become a melted mess.
> 
> Note, this press uses a 15A fuse rated at (at least) 125v.  (Kyle, can you pick one of these up for it?)
> There is a note on it now to Plug it in when using it and unplugging it when done.  This will likely keep the fuse from blowing since there won't be an inductive spark / surge across the live power switch.
> I'd appreciate someone adding that info to the wiki.
> 
> 
> What I did:
> 1) Fixed the connection on the power switch and soldered one of the loose clamp terminals
> 
> 2) re routed wires for the fuse to the outside and installed fuse holder externally
> 
> 3) put shittons of tape on everything
> 
> 4) wrote notes on how to use
> 
> 
> Time will tell if this fix will last but I think it will be OK.  LED display aside, there are no circuits to speak of in this thing and it is a "dumb" heating element attached to a transformer / relay.
> 
> 
> -Zach
> 
> 
> 
>  
> From: noisebridge-discuss-bounces at lists.noisebridge.net <noisebridge-discuss-bounces at lists.noisebridge.net> on behalf of Kyle Ng <ng.kyle at gmail.com>
> Sent: Tuesday, January 19, 2016 8:12 AM
> To: noisebridge-discuss at lists.noisebridge.net
> Subject: Re: [Noisebridge-discuss] Heat press fixed!
>  
> I went out and found a microwave fuse that was the right rating.
> Also, Chris from CHM helped be track down a broken solder joint and repaired it. He's really good at soldering and it seems safer than it used to be!
> 
>> On Mon, Jan 18, 2016 at 8:25 AM, jarrod hicks <hicksu at gmail.com> wrote:
>> Thank you for sending a message to the list to alert others to the
>> condition of the heat press and what has been done to attempt to
>> repair it.
>> 
>> On Fri, Jan 15, 2016 at 3:29 PM, Kyle Ng <ng.kyle at gmail.com> wrote:
>> > The last time I used the heat press it was perfectly functional, but some
>> > people wanted to use it recently and found that it was not heating up nor
>> > displaying the temperature.
>> >
>> > They removed the fuse and dropped it on the ground, breaking it. I went to
>> > buy a new fuse today. The old one had the markings F25A250V. However, I
>> > could only find a 25A 32V fuse at O' Reilly's so I went ahead and put that
>> > in. No luck and same symptoms.
>> >
>> > I opened up the back to see if anything was visibly melted but I couldn't
>> > find anything wrong. I think the temperature controller is messed up.
>> >
>> > _______________________________________________
>> > Noisebridge-discuss mailing list
>> > Noisebridge-discuss at lists.noisebridge.net
>> > https://www.noisebridge.net/mailman/listinfo/noisebridge-discuss
>> >
> 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.noisebridge.net/pipermail/noisebridge-discuss/attachments/20160319/413af15b/attachment.html>


More information about the Noisebridge-discuss mailing list