[Noisebridge-discuss] Flashforge issues

Phillip Pearson pp at myelin.nz
Thu May 5 22:15:33 UTC 2016


I see we have a new 3D printer in the space...?  A black CTC Makerbot
Dual clone, looks like a CTC BIZER (not the BIZER II or III).
Couldn't connect to it though -- it seems to enumerate as ATMEGA8U2
DFU, which looks like it's missing its serial port firmware.  I found
some Makerbot firmware for the 8U2 chip, but dfu-programmer on my Mac
complained that the bootloader and code overlap, so I decided to leave
it alone rather than force anything that I didn't understand.

Failing to use that, I put the old Flashforge Creator back on the
table next to Threed, and I'm running a test on it right now.  It's
successfully printed for 6.5 minutes so far, running ReplicatorG (as
in: cd replicatorg-0040; sudo ./replicatorg) and printing a half-scale
version of the '3D_Knot' example.  Making a bit of a hash of it but
that's probably just me running the extruder/platform too hot.
Haven't been seeing any serial connection issues there.

Can anyone fill in a bit more details on the new CTC printer etc?  Has
anyone successfully used it over USB?

Cheers,
Phil

On Mon, May 2, 2016 at 4:18 PM, Phillip Pearson <pp at myelin.nz> wrote:
> It's super picky about SD cards; I believe Sailfish has wider
> compatibility, but the stock firmware requires pretty old cards AFAIK.
> I talked to Miloh about updating to Sailfish some months ago and he
> suggested a different firmware that I can't remember right now.
>
> As for the foreground/background thing, you're doing it right with
> ReplicatorG in the foreground.  It loses its connection regularly if I
> run ReplicatorG in the background on my MacBook Pro, but it runs fine
> in the foreground, and it runs fine as long as it's in the foreground
> on the 'threed' machine.
>
> I haven't been in for a month or so though, so I can't confirm with
> recent results.  Anyone else tried using the Flashforge recently?
>
> Cheers,
> Phil
>
> On Sun, May 1, 2016 at 9:18 PM, Adrian Kelly <ahalekelly at gmail.com> wrote:
>> Tried it again today. Brought in an 8GB SD card, formatted it to a single
>> 2GB FAT16 partition like the internet said. Imported some Slic3r gcode into
>> ReplicatorG, exported an x3g file, and the printer said "SD Card Read
>> Error." Tried again with a 1GB partition and no luck. Maybe I'll try a real
>> 2GB SD card next, or slicing in ReplicatorG.
>>
>> On Sat, Apr 30, 2016 at 11:17 PM, Adrian Kelly <ahalekelly at gmail.com> wrote:
>>>
>>> Yeah I left the ReplicatorG GUI window in the foreground, didn't open
>>> anything else on that computer. Alt-Tabbing between windows didn't reconnect
>>> like the wiki said it would. Should I have put the terminal window in the
>>> foreground?
>>>
>>> On Sat, Apr 30, 2016 at 11:12 PM, Phillip Pearson <pp at myelin.co.nz> wrote:
>>>>
>>>> Did you have ReplicatorG in the foreground, or did you switch over to
>>>> another app after kicking off the print? I find that it loses its serial
>>>> connection if you have it in the background. My trick is to scp my stl or
>>>> gcode files over to threed.local and run ReplicatorG in the foreground there
>>>> (and turn off the display auto lock in the power saving settings while I'm
>>>> at it).
>>>>
>>>> Cheers,
>>>> Phil
>>>>
>>>> Sent from my iPhone
>>>>
>>>> On Apr 30, 2016, at 10:02 PM, Adrian Kelly <ahalekelly at gmail.com> wrote:
>>>>
>>>> Hey all,
>>>>
>>>> I spent a couple hours today trying to do my first print, and the serial
>>>> connection to the printer kept disconnecting. I tried multiple cables,
>>>> rebooted both the desktop computer and printer several times, and never made
>>>> it through the first layer. It seemed to be getting worse, and by the end,
>>>> it wouldn't even make it through preheat before the serial connection
>>>> dropped. Does anyone know why this is happening? The wiki said it might be
>>>> because other programs are using too much processing power, but ReplicatorG
>>>> was the only program open. I'll be back tomorrow with an SD card and will
>>>> try it that way.
>>>>
>>>> I was also reading about the Sailfish firmware and it sounds like it's a
>>>> more reliable and better maintained firmware. The Makerbot firmware we're
>>>> running now actually uses the Sailfish back end, forked in 2012, and
>>>> Sailfish is fully compatible with all the same software as the Makerbot
>>>> firmware. Are there any objections to switching?
>>>>
>>>> Adrian Kelly
>>>>
>>>> _______________________________________________
>>>> Noisebridge-discuss mailing list
>>>> Noisebridge-discuss at lists.noisebridge.net
>>>> https://www.noisebridge.net/mailman/listinfo/noisebridge-discuss
>>>
>>>
>>


More information about the Noisebridge-discuss mailing list