[Rack] noisebridge.net:80 timing out/slow to respond.

Andy Isaacson adi at hexapodia.org
Fri Nov 11 13:57:27 PST 2011


On Fri, Nov 11, 2011 at 12:21:46PM -0800, Jonathan Lassoff wrote:
> On Fri, Nov 11, 2011 at 12:05 PM, Rubin Abdi <rubin at starset.net> wrote:
> > Leif says it might be because of Mitch talking on KQED. Can anyone with
> > credentials hit the box?
> 
> Indeed. Seeing the same here (hitting the Cernio box. Is it a VM?).
> 
> TCP connections are made just fine, but there is a long delay before a
> response after flushing an HTTP request through.
> High load?
> 
> TCP/443 / HTTPS is exhibiting the same behavior. Presumably, it's the
> same daemon as TCP/80.

Yes, 80 and 443 are on the same daemon.

We saw a lot of usage around 10:15 - 11:15, peaking at 260 GET/min at
10:20:

% tail -n 30000 /var/log/apache2/wiki-ssl-access.log | cut -d' ' -f4 | cut -d: -f1-3 | uniq -c | sort -n | tail
    221 [11/Nov/2011:10:23
    221 [11/Nov/2011:10:39
    221 [11/Nov/2011:10:53
    224 [11/Nov/2011:11:00
    227 [11/Nov/2011:11:24
    233 [11/Nov/2011:10:29
    238 [11/Nov/2011:10:37
    241 [11/Nov/2011:11:10
    261 [11/Nov/2011:10:20

Everything seemed to be calmed down well before 12:21, though.

    121 [11/Nov/2011:12:11
     54 [11/Nov/2011:12:12
     85 [11/Nov/2011:12:13
     72 [11/Nov/2011:12:14
     64 [11/Nov/2011:12:15
     20 [11/Nov/2011:12:16
     75 [11/Nov/2011:12:17
     31 [11/Nov/2011:12:18
     47 [11/Nov/2011:12:19
     67 [11/Nov/2011:12:20
    166 [11/Nov/2011:12:21
     83 [11/Nov/2011:12:22
      1 [11/Nov/2011:12:23
      1 [11/Nov/2011:12:22

The VM definitely chugged pretty bad at some of those times.  We need to
move it to a less ancient host, as Ben points out.

-andy


More information about the Rack mailing list