[Rack] serial ports on minotaur

Jake jake at spaz.org
Fri Feb 1 08:03:07 UTC 2013


So i'm trying to connect the RFID reader to minotaur.  It has a serial 
port (its ethernet does not work) and i figured that since serial ports on 
minotaur are an issue, i would just stick the RS232 to USB adaptor in a 
USB port.

this sort of works, but it fucks up and says
RRd,d67,t:841EC{EPC1G2{Rd,467,t2;DF
63AC1005FB6F
{RdRd05FB6341EC8Rd,d:3005FB63A005FB6F
Rd,C1F384Rd,d{7,t:EP05FB63
FB63A3005FBRdRd,d67,t:E841EC{5FB63A:EPC1G2;DF
{R3AC1F880467F
5FB63467,t:3005FBDF
B63AC1RdC1F380467,tRd5FB63ADF
when it should be saying
{Rd,d:3005FB63AC1F3841EC880467,t:EPC1G2,e:28;14
{Rd,d:3005FB63AC1F3841EC880467,t:EPC1G2,e:28;14
{Rd,d:3005FB63AC1F3841EC880467,t:EPC1G2,e:28;14
{Rd,d:3005FB63AC1F3841EC880467,t:EPC1G2,e:28;14
{Rd,d:3005FB63AC1F3841EC880467,t:EPC1G2,e:28;14

I think this is because the delicate USB to serial adaptor can't handle 
the RF pounding it's receiving (although if you think it's a software 
error by all means..).  It works when i unplug and replug the USB.. for a 
little while.

so i want to use a real serial port.  So i tried to figure out what ports 
were actually being used and there's no wiki for it, so i tried to run 
lsof to see what was up and guess what

root at minotaur:/home/jake# lsof
Segmentation fault
root at minotaur:/home/jake#

so whatever.  Also i will need a serial port for the new doorkeypad that 
will go at the top of the stairs (for buzzing people in).

Can we figure out how many serial ports this motherboard actually has and 
how many are in use and how many can be made available?

thank you
-jake


More information about the Rack mailing list