[Rack] minotaur parallel port died! gate won't open!

Jonathan Lassoff jof at thejof.com
Tue Jul 30 03:26:53 UTC 2013


Aww, crap! This is a real bummer to me. Seems like the parallel port is
being disconnected and reconnected semi-rapidly. Nothing looks wrong with
the host configuration.

This log line makes me the most curious:

Jul 29 17:45:55 minotaur kernel: [2057257.594620] hub 1-1:1.0: port 2
disabled by hub (EMI?), re-enabling...


Perhaps the hub is under-powered, or there is some noise or EMI coming
through the line? How does the parallel port connect electronically?
If I recall, there is no electrical isolation between the door system and
the parallel port device.

If it's under-powered, I recall there being a port on the little octopus
USB hub to take in some DC power. Perhaps we should power that?

Thoughts?

Cheers,
jof



On Mon, Jul 29, 2013 at 6:58 PM, Jake <jake at spaz.org> wrote:

> i am going to try rebooting minotaur.  Jof please help!
>
> the damn parallel port might be fucking up!  the gate won't open by
> minotaur's control!  here's the line from lsusb:
>
> Bus 001 Device 019: ID 1293:0002 Belkin Components [hex] F5U002 Parallel
> Port [uss720]
>
> and this is the last part of syslog:
>
> ul 29 17:45:40 minotaur kernel: [2057241.789649] usb 1-1.2: New USB device
> strings: Mfr=0, Product=0, SerialNumber=0
> Jul 29 17:45:40 minotaur kernel: [2057241.945661] parport6: fix this
> legacy no-device port driver!
> Jul 29 17:45:40 minotaur kernel: [2057241.946148] lp6: using parport6
> (polling).
> Jul 29 17:45:55 minotaur kernel: [2057257.594620] hub 1-1:1.0: port 2
> disabled by hub (EMI?), re-enabling...
> Jul 29 17:45:55 minotaur kernel: [2057257.594638] usb 1-1.2: USB
> disconnect, device number 14
> Jul 29 17:45:56 minotaur kernel: [2057257.810667] usb 1-1.2: new
> full-speed USB device number 15 using ehci_hcd
> Jul 29 17:45:56 minotaur kernel: [2057257.918658] usb 1-1.2: New USB
> device found, idVendor=1293, idProduct=0002
> Jul 29 17:45:56 minotaur kernel: [2057257.918658] usb 1-1.2: New USB
> device strings: Mfr=0, Product=0, SerialNumber=0
> Jul 29 17:45:56 minotaur kernel: [2057258.074650] parport7: fix this
> legacy no-device port driver!
> Jul 29 17:45:56 minotaur kernel: [2057258.075144] lp7: using parport7
> (polling).
> Jul 29 18:11:11 minotaur kernel: [2058773.377566] hub 1-1:1.0: port 2
> disabled by hub (EMI?), re-enabling...
> Jul 29 18:11:11 minotaur kernel: [2058773.377566] usb 1-1.2: USB
> disconnect, device number 15
> Jul 29 18:11:11 minotaur kernel: [2058773.593396] usb 1-1.2: new
> full-speed USB device number 16 using ehci_hcd
> Jul 29 18:11:12 minotaur kernel: [2058773.701388] usb 1-1.2: New USB
> device found, idVendor=1293, idProduct=0002
> Jul 29 18:11:12 minotaur kernel: [2058773.701388] usb 1-1.2: New USB
> device strings: Mfr=0, Product=0, SerialNumber=0
> Jul 29 18:11:12 minotaur kernel: [2058773.857378] parport8: fix this
> legacy no-device port driver!
> Jul 29 18:11:12 minotaur kernel: [2058773.857576] lp: ignoring parallel
> port (max. 8)
> Jul 29 18:14:13 minotaur kernel: [2058954.880911] hub 1-1:1.0: port 2
> disabled by hub (EMI?), re-enabling...
> Jul 29 18:14:13 minotaur kernel: [2058954.880911] usb 1-1number 17 using
> ehci_hcd
> Jul 29 18:14:13 minotaur kernel: [2058955.208732] usb 1-1.2: New USB
> device found, idVendor=1293, idProduct=0002
> Jul 29 18:14:13 minotaur kernel: [2058955.208732] usb 1-1.2: New USB
> device strings: Mfr=0, Product=0, SerialNumber=0
> Jul 29 18:14:13 minotaur kernel: [2058955.364724] parport8: fix this
> legacy no-device port driver!
> Jul 29 18:14:13 minotaur kernel: [2058955.364925] lp: ignoring parallel
> port (max. 8)
> Jul 29 18:14:39 minotaur kernel: [2058980.994742] hub 1-1:1.0: port 2
> disabled by hub (EMI?), re-enabling...
> Jul 29 18:14:39 minotaur kernel: [2058980.994742] usb 1-1.2: USB
> disconnect, device number 17
> Jul 29 18:14:39 minotaur kernel: [2058981.210373] usb 1-1.2: new
> full-speed USB device number 18 using ehci_hcd
> Jul 29 18:14:39 minotaur kernel: [2058981.318363] usb 1-1.2: New USB
> device found, idVendor=1293, idProduct=0002
> Jul 29 18:14:39 minotaur kernel: [2058981.318363] usb 1-1.2: New USB
> device strings: Mfr=0, Product=0, SerialNumber=0
> Jul 29 18:14:39 minotaur kernel: [2058981.474353] parport8: fix this
> legacy no-device port driver!
> Jul 29 18:14:39 minotaur kernel: [2058981.474550] lp: ignoring parallel
> port (max. 8)
> Jul 29 18:17:01 minotaur /USR/SBIN/CRON[31005]: (root) CMD (   cd / &&
> run-parts --report /etc/cron.hourly)
> Jul 29 18:19:07 minotaur kernel: [2059249.283512] hub 1-1:1.0: port 2
> disabled by hub (EMI?), re-enabling...
> Jul 29 18:19:07 minotaur kernel: [2059249.283512] usb 1-1.2: USB
> disconnect, device number 18
> Jul 29 18:19:07 minotaur kernel: [2059249.503147] usb 1-1.2: new
> full-speed USB device number 19 using ehci_hcd
> Jul 29 18:19:07 minotaur kernel: [2059249.611131] usb 1-1.2: New USB
> device found, idVendor=1293, idProduct=0002
> Jul 29 18:19:07 minotaur kernel: [2059249.611131] usb 1-1.2: New USB
> device strings: Mfr=0, Product=0, SerialNumber=0
> Jul 29 18:19:08 minotaur kernel: [2059249.767122] parport8: fix this
> legacy no-device port dritftp[5190]: file /var/lib/tftpboot/init.cfg not
> found
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.noisebridge.net/pipermail/rack/attachments/20130729/f7ad39dc/attachment.html>


More information about the Rack mailing list