[Rack] api.noisebridge.net problems

Jake jake at spaz.org
Tue Jul 30 06:28:55 UTC 2013


i think it might be related to a seperate problem, like maybe baron can't 
open the door-open API so it's failing with an error code, and so it gets 
respawned?  i don't know.

i can't tell if the problem is with monit, or baron, or something else.. 
when i type in a valid code, the keypad makes a weird sound like it is 
being sent a sad and then happy sound, which i think means an API error..

yes, i get this:

jake at minotaur:/etc/monit$ curl -X POST -d open=1 
http://api.noisebridge.net/gate/

     <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
     <html>
         <head>
             <title>Error 500: Internal Server Error</title>
             <style type="text/css">
               html {background-color: #eee; font-family: sans;}
               body {background-color: #fff; border: 1px solid #ddd;
                     padding: 15px; margin: 15px;}
               pre {background-color: #eee; border: 1px solid #ddd; 
padding: 5px;}
             </style>
         </head>
         <body>
             <h1>Error 500: Internal Server Error</h1>
             <p>Sorry, the requested URL 
<tt>'http://api.noisebridge.net/gate/'</tt>
                caused an error:</p>
             <pre>Internal Server Error</pre>
         </body>
     </html>

On Mon, 29 Jul 2013, Dana wrote:

> I did a ps aux when i was on minotaur earlier and there were like 20 instances of baron running, probably not normal?
>


More information about the Rack mailing list