20 March 2017: Continue Spreads Install on a Mac Mini

From Noisebridge
Jump to: navigation, search
  • Quite a lot of effort went into getting Spreads working on a Mac Mini running macOS Sierra.
  • Running the build against a swath of node.js versions yielded the optimal version for Spreads: 0.10.48, which was from 2014
  • This version was untenable, because many of the libraries built for it were *deprecated years ago*
  • Spreads could be gotten working again by modernizing its framework usage, but since it is a web app built for browsers many versions older than today's, that effort will be expensive
  • PDFScanner and ABBYY FineReader Pro provide acceptable results, though it would've been good to know what results Spreads was capable of