Laser Manual/Workflows

From Noisebridge
Jump to: navigation, search

This is the overall workflow for the laser cutter. Each part is elaborated below.

  1. Laser start up
  2. Material setup
  3. Convert file to DXF
  4. Load file onto the machine
  5. Dry run
  6. Cut/Engrave
  7. Laser shut down
  8. Cleanup


Laser start up[edit]

Laser chiller
The laser chiller is the box on the bottom left of this photograph. If the laser doesn't beep when it turns on, you should turn on the chiller manually.
  1. Turn on power and ensure that the fan and chiller are running. If you do not hear beeps when the laser starts up, the chiller is not running and you must turn it on.
  2. Move the head as far forward and right as possible, close to the controls


Material setup[edit]

  1. Clean the bed of any scraps that may be on it
  2. Move the cut head as far forward and right as possible (near the controls)
  3. Raise the laser head as far up as possible
  4. Raise the bed to the desired height, watching the laser head to avoid crashes
  5. Move the laser head as far back and right as possible
  6. Place material on the bed
  7. Focus the laser (do at least for each distinct thickness, optimally do for each piece of material)


Focusing the laser[edit]

Shelf by laser cutter
This is the shelf to the left of the laser cutter. The acrylic disks used for focusing the laser are in the toolbox with the yellow lid.

Noisebridge has acryllic disks cut to various thicknesses that can be used to accurately focus the laser. Specifically the laser head needs to be locked to 8mm above the surface of the material you're cutting.

  1. Place the material on the cut bed
  2. Move the cut head to the center of the area to cut, watching the laser head to avoid crashes w/ material
    1. Note that the honeycomb bed can move up and down (Z-axis) so if the material doesn't fit under, hit Z/U on the laser controls and navigate the menu until Z axis (or something similar) is selected. Then use the left and right arrows to move the bed up and down.
  3. Loosen the wing nut and raise the head all the way up
  4. Place the focusing discs on the material under the head
  5. Lower the head until it just touches the focusing disc (8mm above material)
  6. When you focus the laser, ALWAYS make sure the metal adaptor for the air hose is facing straight towards you
  7. Lock the head in place (tighten the wing nut)
  8. Remove the focusing discs

Convert an image in Inkscape to a DXF file[edit]

  1. Load the image into Inkscape
  2. Set the different cut paths to different colors (for controlling settings, etc.)
  3. Perform any debugging steps (by default you should perform all of them b/c of errors in the laser software)
  4. Save as a DXF. Be sure to make the units be millimeters so that importing later will correctly scale the image.


Debugging DXF Problems[edit]

Sometimes exporting to DXF introduces bizarre extra lines. Usually this is because your artwork includes elements that aren't paths (a.k.a. Bézier splines), such as text objects or clones of other elements. Here are some things to try in Inkscape (especially the last one):

  1. Select any and all Clones and choose Edit > Clone > Unlink Clone. (If it's not enabled, just skip it.)
  2. Select any and all Groups and choose Object > Ungroup. Repeat until the menu item is disabled. (If it's not enabled, just skip it.)
  3. Select all objects that aren't paths (such as text objects) and convert them to paths with Path > Object to Path.

If this fails to resolve the issue, you can try a more radical solution which will eliminate all bezier paths entirely:

  1. Select all the problematic shapes
  2. Convert bezier paths to lines (Extensions > Modify Path > Flatten Bezier).

Flatness 0.5 is good to start with. Smaller = better approximation of the curves. A lower flatness number takes more time to compute, but also produces a better approximation to the curve. Be sure to ungroup (sometimes multiple times) before trying this, as grouped objects cannot be flattened as a group. This is especially important for text which is by default a group (each character being a separate object in Inkscape once you've turned it into a path).

Sometimes need to select the path's directly with the path tool (but not the points!).

Also see http://www.pstoedit.net/ for conversion from svg to dxf files.

Loading into the laser cutter software[edit]

  1. Import the file with File > Import
  2. Resize as needed, tho if the file was exported w/ millimeter units, the software should also import the image with the correct size.
  3. Set the cut order:
      • EITHER Set the cut order to inside-out (Handle > Cut optimize > Inside to outside)
      • OR Manually specify cut order with the Set cut property tool (Edit > Set cutting property). See below for more details.
  4. Set the speed and power for the layers as necessary, and the process mode for each layer to either cut (for continuous line cutting) or dot (for dashed line cutting) or scan (for engraving)
  5. Optionally, simulate the cutting/engraving process.
  6. Download to the machine (Laser Work panel on the bottom right).

Manually specifying cut order[edit]

In the Set cutting property window (Edit > Set cutting property), you can manually re-order the cut paths. In the window, you'll see an image of the workpiece, and to its right, two lists of paths. When you first open the window, all of the cut paths are in the left. If you select a path (either in the image or in the list) and click the button labeled ">>", this path will be transferred to the end of the right list of paths. If you click ">>>", all of the paths in the left list will be moved to the end of the right list (preserving order). Similarly, clicking "<<<" will move the right list to the end of the left list. If you select a cut path in the right list, the up and down arrow buttons will reorder that path in the chosen direction.


Loading speed and power settings from library[edit]

  1. In the top right panel, double click the layer of interest
  2. Click "Load parameters from library"
  3. Select the library item
  4. Click "Load"


Saving power and speed settings to library[edit]

  1. In the top right panel, double click the layer of interest
  2. Make sure the layer is set to the desired parameters
  3. Click "Load parameters from library"
  4. Click "Save as"
  5. Enter a name and optionally some notes
  6. Click "Ok"


Simulation[edit]

  1. Open the simulation window with either Edit > Preview or the toolbar button labelled with a monitor.
  2. Click the Simulation button in the right panel


Cutting[edit]

  1. Select the file to use using the File button
  2. Move the head to the initial guess origin with the arrow buttons
  3. Test the frame with the Frame button adjust origin as necessary
  4. Set the origin by pressing Origin
  5. Test the cut by turning the laser power off and pressing the Start/Pause button
  6. Turn the laser power on
  7. Cut by pressing the Start/Pause button
  8. It is generally a good idea to put the laser head into one of the top corners and resetting origin before opening the laser if you plan on adding new material to avoid collisions with a moving head.


Engraving[edit]

In the laser software, open the layers you wish to engrave in the layer parameters panel, and send the processing mode to "Scan". This will do a raster scan of the region bounded by the paths in that layer. An even-odd rule is used to assign regions to the "inside" vs "outside" of the engraving.

Cancel a cut/dry run[edit]

  1. Pause with the Start/Pause button
  2. Cancel and move back to the origin with the Esc button


Laser shut down[edit]

  1. Move the head as far forward and right as possible (near the controls)
  2. Raise the laser head as far up as possible
  3. Set origin with the origin button (this helps avoid the laser swinging across the bed later)
  4. Let the fan run for a little bit (~30 seconds)
  5. Turn the power off


Cleanup[edit]

Laser bottom tray
This is the bottom tray of the laser, which should be cleaned out after use.
  1. Remove pieces of material scrap left on the bed
  2. Open the tray door on the front bottom and empty the scraps left there


Calculating work time[edit]

On the computer:

  • Open the simulation window (see above). Total work time and time of laser use are displayed in the top right. Donations should be calculated by laser use, not total work time.

On the machine:

  • Whole file: File > Select file > Right Arrow > Work Time > Enter
  • Current run: Pause the cut, then check time at the bottom right

Fusion 360[edit]

Fusion 360 is a free CAD (Computer Aided Design) program from Autodesk for designing 3D parts, and arguably the best one currently available. If you're designing something complex on the laser cutter, particularly with multiple parts that need to fit together, I highly recommend it over drawing programs like Inkscape. It also has CAM (Computer Aided Manufacturing) capabilities, which makes it very useful for CNC machining and laser cutting. There's a copy of the software on the laser cutter computer, and you can download it here. It's free as long as you make less than $100k per year using it.

Workflow 1: The Quick and Dirty Way[edit]

This is the fastest way, and works a lot of the time

  1. Make sure your sketch only contains straight lines, arcs, and circles, and no spline curves. If your sketch has splines, go to #Workflow 3: The Long Way
  2. Make sure your part is designed using a single sketch, and that you want to cut all the lines in that sketch. If not, go to #Workflow 2: The Middle Ground
  3. Right click on your sketch and click Save As DXF
  4. Import the DXF in RDWorks, and continue with the standard workflow starting at #Loading into the laser cutter software

Workflow 2: The Middle Ground[edit]

If you're not sure, this is probably where you should start.

  1. Make sure your sketch only contains straight lines, arcs, and circles, and no spline curves. If your sketch has splines, go to #Workflow 3: The Long Way
  2. Right click on the top surface of the part you want to cut, and click Create Sketch
  3. Hit the P key to open the Project dialog box, then select the top surface of your part, and any other lines you want to cut
  4. Hit OK, then remove any lines you don't want cut
  5. Open the Sketches folder near the top of the tree, then right click your new sketch and click Save As DXF
  6. Import the DXF in RDWorks, and continue with the standard workflow starting at #Loading into the laser cutter software

Workflow 3: The Long Way[edit]

This allows more complicated things like exporting splines, which doesn't work with the above methods, kerf compensation, which makes your parts fit together snugly, but you can also use the above methods and then do it in RDWorks, or lead-ins and lead-outs, which can make for a cleaner cut, but I can't figure out how to get RDWorks to import correctly.

  1. Design a part to be laser cut by drawing a 2D sketch and extruding it
  2. Go to the CAM workspace by clicking the Model button in the top left, then selecting CAM
  3. Select the Waterjet operation (if you don't see this, turn it on under Preferences -> Preview)
    1. Set Type to Laser Cutting
    2. Select the Cutting Mode, either Through - Auto or Etch
    3. Look up the kerf of the material you're cutting in the #Known good materials section, and enter that in Kerf Width, or if your material's not listed, cut one a kerf gauge and put the result in the wiki. The kerf changes depending on the thickness, speed and power. Setting a larger kerf width will make your parts fit tighter, and setting a smaller kerf will make them looser.
    4. Select the contours of your part that you want to cut
    5. Go to the Passes tab, and change Compensation Type to In Computer
    6. Hit OK to close the dialog box, and you can see a preview of your tool path. You can go back to edit it by double clicking the contour operation in the tree on the left
  4. To export to DXF, click the Post Process button, which says G1 G2. Make sure rdworkslaser is selected as your post processor, type a name for the export and hit Post. Then select the folder to put it in.
  5. Import the DXF in RDWorks, and continue with the standard workflow starting at #Loading into the laser cutter software
  6. Fusion automatically orders the cuts from inside out and in the fastest order, but RDWorks doesn't always respect that order, so you may need to optimize the cut order again

Advanced Options[edit]

  1. If you're using your own computer for the first time and not the laser cutter desktop, you have to enable the laser cutter support which is still in beta, by clicking on your name in the top right, then Preferences, Preview, and checking "CAM - Waterjet/Laser/Plasma cutter support". You will also need to download the custom post processor that we use for this laser.
  2. There's a simulate button to the left of the Post Process button, if you want to do it in Fusion
  3. If you want to disable or tweak the lead ins and lead outs, you can go to the Linking tab. Lead ins and lead outs can fix the bump you get on the side of your part where the laser started and stopped, but they also make extra cuts in your scrap material, which you may want to keep. In this tab you can also specify the Entry Position for each cut path.
  4. You can disable Kerf Compensation by settting Sideways Compensation to Center under the Passes tab, though this is not recommended


Techniques[edit]

Kerf Compensation[edit]

For any given layer, you can compensate for the kerf (width of the cut) by opening it's settings and clicking the "Advance" button next to the "Seal" input box towards the middle-bottom. Enable sew compensation, and pick the direction and sew width (kerf size). The inward direction will make the actual cut move toward the inside of a closed cut path, outward will move it towards the outside.

In general, for cuts on the outside, you want to move outward, to move the actual cut edge be exactly where the path is in your design. For cuts on the inside, you want to use the inward direction.

Negative Space Engraving[edit]

You can engrave a vector shape with a hole in the middle of it, so that you get enclosed portions that are not engraved in the middle of fully engraved portions. To do this, when you construct the image in your editor of choice, simply perform subtraction between the relevant paths, to remove the inner part. In the RDWorks laser software, the two paths will show up, and be independently editable (making them look like just two distinct paths to engrave), but they will engrave correctly as a negative space. Obviously test this w/ your software; this technique is known to work using Inkscape.

Nest & Waste Less Material[edit]

As of 01/2018 you can use the industrial strength Deepnest installed on the Laser Cutter computer + Collaboration Station in Hackitorium. We have an unlimited subscription available to laser users, which is compatible with both DXF, Corel CDR and SVG formats. Please ask if you need login credentials. Also available from the same author for free is SVGNest, which can be used by clicking here.

Text Cutting[edit]

In Inkscape, after converting the text object to a path, it's necessary to ungroup the text as well, to create separate paths, prior to flattening the bezier curves.

If you're using a cursive font and want everything to be one piece, convert the text object to a path, and use Path > Union. This tool in general is quite useful for merging paths that have been independently drawn but need to be merged into a single path. For example, if you made two overlapping circles, without this the cutter would just cut the two circles, which leads to a lemon-shaped piece in the center. If you union the paths, it will cut an outline as well. Path > Union will not make any holes in the figure go away, it only gets rid of cuts passing through area covered by another shape.

Engraved text requires no other special technique because no cuts are made, but text cutting is non-trivial. Because of loops, it's sometimes desirable to use a stencil font, especially at smaller scales where legibility is important. 1001 Fonts has a number of stencil fonts for free. At 10pt, some good fonts are Marsh, Spacedock, and Allerta.

Troubleshooting[edit]

File doesn't appear in laser cutter after successful download[edit]

If the laser cutter has 99 files loaded into it, new files will not show up. To fix this, open up RDWorks8, and on the right side, select the Doc tab. Inside that tab, click Read to read all the files in the laser cutter, and then click Delete all.

read files
This is the button used to read stored files from the laser cutter.
delete all files
This is the button used to delete all stored files from the laser cutter to make room for new ones.

Laser cutter doesn't turn on properly[edit]

Symptom: https://youtu.be/AMNTKEAC3R0

This is likely because the e-stop was pressed before, and it needs to be twisted to be released back into its popped-out position.


How do I send files to the Laser computer over the internet?[edit]

Send your files directly to the laser cutter through this URL [1], which is kindly hosted for us by Disroot.org via Nextcloud.

All files are uploaded directly to \My Documents\PUT YOUR FILES HERE (IN YOUR OWN FOLDER)\Uploads for Noisebridge Lasercutter\

Please move any files you upload to your own folder asap.

Ok, I created a folder for my laser cutter files, but can I access them over the internet?[edit]

Yes, this is now possible as of 01/2018.

  1. Double check you made a folder inside \My Documents\PUT YOUR FILES HERE (IN YOUR OWN FOLDER)\
  2. Ping @James on Slack with the name of your folder.
  3. Be sure to mention if you need a password added to your folder.
  4. Wait a day for the share link to be activated and sent to you.

Troubleshooting[edit]

Help! All the menu options turned to gibberish![edit]

The RDWorks software can be buggy. Go to the top menu, the right-most or or 2nd-right-most tab will have a Language option. Select English. When that happens, the bed size settings might also have changed. Double check Config -> Document Settings (?). The proper settings are 1300mm × 900mm. (TODO: need to double check the exact menu labels, doing this from memory at the moment)

SOLIDWORKS[edit]

Apparently DXFs exported from Solidworks (at least v 2017) break when directly imported into RDWorks. The workaround is to import the DXF into Inkscape and re-export it from there.